Degraded Mastercard authorizations for Barclaycard merchants

Incident Report for Bizzon

Resolved

This incident has been confirmed as resolved by Barclaycard.
Posted Mar 22, 2023 - 11:01 UTC

Monitoring

As of 00:38 CET this morning, the problem is resolved - Mastercard transactions from affected BINs are no longer declined.
We are still investigating the root cause with Barclaycard and will update the status when more info is available.
Posted Mar 22, 2023 - 08:45 UTC

Investigating

We are experiencing issues with Mastercard authorizations processed via Barclaycard. Approximately 30% of transactions of Mastercard are being rejected for all Barclaycard-enabled properties. Visa transactions are not affected, as well as other card acquirers. We have contacted Barclaycard and are investigating the issue on our part and will provide more information soon.
Posted Mar 21, 2023 - 15:43 UTC
This incident affected: Payments.