Card payment processing through Bambora is currently experiencing problems
Incident Report for Bizzon
Resolved
We confirm that the service has been resumed. Payment functionality is now fully operational for all acquirers.

This incident has been resolved. We apologize for any inconvenience caused by the service disruption.
Posted Sep 29, 2022 - 18:28 UTC
Monitoring
As of 18:47 CET, we see the transactions being approved again, but we still don't have an official update from the vendor.
We are monitoring the situation and will update you as soon as more information becomes available.
Posted Sep 29, 2022 - 16:57 UTC
Update
The vendor is still working on the solution. We will provide an update as soon as more information is available.
Posted Sep 29, 2022 - 16:39 UTC
Update
The vendor used by Bambora is confirming the issue:
Description: We have noticed that there are interruptions in the network connections that may affect our authorization service. Some of our customers may experience sporadic interruptions.
Status: Troubleshooting is ongoing, next status at 18:20 CET
Posted Sep 29, 2022 - 16:08 UTC
Update
Bambora confirms an ongoing issue with an external payment provider.
Posted Sep 29, 2022 - 15:48 UTC
Identified
Processing through Bambora is currently experiencing problems due to unavailability of downstream services. We monitor the situation and will provide more information when we receive updates from Bambora. Other acquirers are not affected.
Posted Sep 29, 2022 - 15:44 UTC
This incident affected: Payments and Point of Sale.