Inaccurate sales report
Incident Report for Bizzon
Resolved
This incident has been resolved.
Posted Oct 05, 2023 - 07:06 UTC
Monitoring
Our team has implemented a fix and the report export functionality has been fully restored. We are monitoring the performance.
Posted Oct 04, 2023 - 12:13 UTC
Investigating
Our downloadable sales reports are currently displaying inaccurate figures. Our developer team is investigating the root cause and will repair the reports as soon as possible.
Posted Oct 04, 2023 - 10:28 UTC
This incident affected: Dashboard.