Amex service disruption
Incident Report for Bizzon
Resolved
The service is back to normal.
Posted about 1 year ago. Aug 15, 2018 - 21:20 UTC
Identified
We are aware some customers are experiencing Amex card issues and transactions are not going through. We will update when we know more.
Posted about 1 year ago. Aug 15, 2018 - 12:27 UTC
This incident affected: Payments.