Mastercard service disruption
Incident Report for Bizzon
Resolved
The service is back to normal.
Posted about 1 year ago. Jun 12, 2018 - 10:31 UTC
Monitoring
Mastercard have addressed the issue and the transaction decline rate is reducing. We are monitoring the situation and will update when the service disruption is over.
Posted about 1 year ago. Jun 12, 2018 - 09:52 UTC
Identified
We are aware some customers are experiencing Mastercard and Maestro card issues. This is impacting customers across Europe. We will update when we know more.
Posted about 1 year ago. Jun 12, 2018 - 08:40 UTC
This incident affected: Payments.