Visa scheme service disruption
Incident Report for Bizzon
Postmortem

Visa have provided an official statement about the issue: https://www.visaeurope.com/newsroom/news/visa-service-disruption

Posted about 1 year ago. Jun 12, 2018 - 09:55 UTC

Resolved
The service is back to normal.
Posted about 1 year ago. Jun 01, 2018 - 23:07 UTC
Monitoring
Visa have addressed the issue and the transaction decline rate is reducing. We are monitoring the situation and will update when the service disruption is over.
Posted about 1 year ago. Jun 01, 2018 - 21:23 UTC
Update
The Visa service disruption is still ongoing. It is preventing some Visa transactions in Europe from being processed. We will update when we know more.
Posted about 1 year ago. Jun 01, 2018 - 20:01 UTC
Update
We are aware some customers are experiencing Visa debit card issues. This is impacting multiple banks across Europe. We will update when we know more.
Posted about 1 year ago. Jun 01, 2018 - 16:52 UTC
Identified
We are aware some customers are experiencing Visa debit card issues. This is impacting multiple banks across Europe. We will update when we know more.
Posted about 1 year ago. Jun 01, 2018 - 16:49 UTC
This incident affected: Point of Sale.