Severely degraded app performance
Incident Report for
Mews POS
Resolved
This incident has been resolved.
Posted
Nov
08
,
2023
-
19:55
UTC
Investigating
Severely degraded POS app performance lasting from 19:15 until 20:55 UTC. The service has been fully restored and more information on this incident will be posted at a later date.
Posted
Nov
08
,
2023
-
19:15
UTC
This incident affected: Point of Sale.
×
Subscribe to Incident
Subscribe to updates for
Severely degraded app performance
via . You'll receive .