Severely degraded service

Incident Report for Bizzon

Resolved

This incident has been resolved.
Posted Mar 27, 2025 - 07:24 UTC

Monitoring

A fix has been implemented, and we are monitoring the situation.
Posted Mar 26, 2025 - 21:05 UTC

Investigating

We are currently experiencing degraded service, and are investigating the issue.
Posted Mar 26, 2025 - 20:32 UTC
This incident affected: Payments, Point of Sale, and Dashboard.