Degraded service
Incident Report for Bizzon
Resolved
The service has been fully restored and more information on this incident will be posted at a later date.
Posted Feb 01, 2024 - 01:36 UTC
Monitoring
The service has been fully restored and more information on this incident will be posted at a later date.
Posted Jan 31, 2024 - 21:28 UTC
This incident affected: Point of Sale and Dashboard.