Version 4.1.1.5 released
Incident Report for
Mews POS
Resolved
This incident has been resolved.
Posted
Jan
25
,
2023
-
10:00
UTC
Monitoring
A new 4.1.1.5 version has been submitted to Play Store. This version contains improvements to the printing logic.
Posted
Jan
18
,
2023
-
11:47
UTC
×
Subscribe to Incident
Subscribe to updates for
Version 4.1.1.5 released
via . You'll receive .