Increased card transactions decline rate
Incident Report for Bizzon
Resolved
This incident has been resolved.
Posted over 1 year ago. May 04, 2018 - 11:55 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted over 1 year ago. May 04, 2018 - 11:50 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted over 1 year ago. May 04, 2018 - 11:40 UTC
Update
We are continuing to investigate this issue.
Posted over 1 year ago. May 04, 2018 - 11:27 UTC
Investigating
We are currently investigating this issue.
Posted over 1 year ago. May 04, 2018 - 11:22 UTC
This incident affected: Payments.